当前位置:首页 > 问答

通达信随意画线

我来帮TA回答

有没有在炒股软件里随意划线的软件?

画线软件目前手机版本应该还没有出现的吧,都是电脑版本的,我一般都用通达信和同花顺,当然我一般也不咋用画线的,你看盘久了就有了盘感,画线实在多此一举

通达信指标中如何自动画线

自动画线太多了,给你一个我看好的,源码下面网址里有图片演示.
该指标能够做到对前期高点和最近高点的连线、前期低点和最近低点的连线、阻力位和支撑位的平行直线的连线,可以说简单易懂,一目了然。这类指标要用到未来函数,通常不做为买卖信号的参考。但该指标在一定周期内根据K线的走势所画的线已经成立,因此股价突破前高或颈线的点位还是比较可靠的,大家不妨在实战中来验证。所以,除了主图以外,还编制了选股指标。
指标中的实线为高、低点连线,虚线为阻力位和支撑位。
该指标可以复制粘贴到任何主图里。
MA7:MA(C,7),COLORWHITE;
MA14:MA(C,14),COLORYELLOW;
MA25:MA(C,25),COLORFF00FF;
MA120:MA(C,120),COLORFFCC66;
QA:=REF(H,10)=HHV(H,2*10+1);
QB:=BACKSET(QA,10+1);
QC:=FILTER(QB,10) AND H=HHV(H,10+1);
QD:=BARSLAST(QC);
QE:=IF(QC,CURRBARSCOUNT,0);
QF:=IF(QD,REF(QE,QD),QE);
QG:=CONST(QF);
QH:=REF(QF,QD+1);
QW:=CONST(QH);
DRAWLINE(CURRBARSCOUNT=QW,H,CURRBARSCOUNT=QG,H,1),COLORGREEN;
DRAWLINE(CURRBARSCOUNT=QW,H,ISLASTBAR,REF(H,QW-1),1),COLOR0099FF,POINTDOT;
DRAWLINE(CURRBARSCOUNT=QG,H,ISLASTBAR,REF(H,QG-1),1),COLOR0099FF,POINTDOT;
QM:=INTPART(3*8/5);
QR:=REF(H,QM)=HHV(H,2*QM+1);
QT:=FILTER(QR,QM);
QY:=BACKSET(QT,QM+1);
QU:=FILTER(QY,QM);
QI:=BACKSET(ISLASTBAR,BARSLAST(QU)+1);
QP:=QI>REF(QI,1);
DRAWLINE(QU,H,QP,H,1),COLORRED;
QA1:=REF(L,8)=LLV(L,2*8+1);
QB1:=BACKSET(QA1,8+1);
QC1:=FILTER(QB1,8) AND L=LLV(L,8+1);
QD1:=BARSLAST(QC1);
QE1:=IF(QC1,CURRBARSCOUNT,0);
QF1:=IF(QD1,REF(L,QD1),L);
QG1:=IF(QD1,REF(QE1,QD1),QE1);
QH1:=CONST(QG1);
QW1:=REF(QF1,QD1+1);
QM1:=REF(QG1,QD1+1);
QR1:=CONST(QM1);
DRAWLINE(CURRBARSCOUNT=QR1,L,CURRBARSCOUNT=QH1,L,1),COLORBLUE;
DRAWLINE(CURRBARSCOUNT=QH1,L,ISLASTBAR,REF(L,QH1-1),1),COLORWHITE,POINTDOT;
DRAWLINE(CURRBARSCOUNT=QR1,L,ISLASTBAR,REF(L,QR1-1),1),COLORWHITE,POINTDOT;
QT1:=REF(L,QM)=LLV(L,2*QM+1);
QY1:=FILTER(QT1,QM);
QU1:=BACKSET(QY1,QM+1);
QI1:=FILTER(QU1,QM);
QP1:=BACKSET(ISLASTBAR,BARSLAST(QI1)+1);
QJ1:=QP1>REF(QP1,1);
DRAWLINE(QI1,L,QJ1,L,1),COLORRED;
SR1:=REF(HIGH,10)=HHV(HIGH,2*10+1);
SR2:=FILTER(SR1,10);
SR3:=BACKSET(SR2,10+1);
HD:=FILTER(SR3,10);
前高:=REF(H,BARSLAST(HD));
DRAWICON(CROSS(C,前高),L-0.20,3);{突破前高的信号}

请教老师如何实现通达信自动画线功能!

画线函数是不能放在选股公式里的应该放在指标公式里,
Ctrl+f 公式编辑器

通达信自己随便画线写字做标记

通达信中主图上怎么把高点低点 也就是颈线 怎么用公式自动画出来 谢谢 求公式

VAR100:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
VAR200:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
VAR300:=(100 - MA(((100 * (HHV(HIGH,5) - CLOSE)) / (HHV(HIGH,5) - LLV(LOW,5))),34));
F:IF(CROSS(VAR200,MA(VAR300,5)),LOW * 0.98,DRAWNULL),CROSSDOT,LINETHICK3,COLOREE00EE;
年:MA(CLOSE,22),LINETHICK2,COLORWHITE;
日:=150;昨前:=3;
高1:=REF(HHV(H,日),昨前);
低1:=REF(LLV(L,日),昨前);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
顶:REFDATE(高1,DATE),COLORRED;
一0.809:REFDATE(H1,DATE),COLORYELLOW;
二0.618:REFDATE(H2,DATE),COLORMAGENTA;
三0.500:REFDATE(H3,DATE),COLORWHITE;
四0.382:REFDATE(H4,DATE),COLORGREEN;
五0.191:REFDATE(H5,DATE),COLORYELLOW;
低:REFDATE(低1,DATE),COLORRED;
VAR31:=HHVBARS(ZIG(3, 19)>REF(ZIG(3,19),1)
AND REF(ZIG(3,19), 1)<REF(ZIG(3,19), 2),0);
STICKLINE(VAR31=2,L*0.95,L*0.98,8,0),COLOR0000FF;
DRAWTEXT(VAR31=2,L*0.95,'3天'),COLORYELLOW;
STICKLINE(VAR31=4,H*1.05,H*1.02,8,0),COLOR9966FF;
DRAWTEXT(VAR31=4,H*1.06,'5天'),COLORYELLOW;
STICKLINE(VAR31=7,L*0.95,L*0.98,8,0),COLOR00FFFF;
DRAWTEXT(VAR31=7,L*0.95,'8天'),COLORYELLOW;
STICKLINE(VAR31=12,H*1.05,H*1.02,8,0),COLORFF33FF;
DRAWTEXT(VAR31=12,H*1.06,'13天'),COLORYELLOW;
STICKLINE(VAR31=20,L*0.95,L*0.98,8,0),COLOR0066FF;
DRAWTEXT(VAR31=20,L*0.95,'21天'),COLORYELLOW;
STICKLINE(VAR31=33,H*1.05,H*1.02,8,0),COLORFFFF00;
DRAWTEXT(VAR31=33,H*1.06,'34天'),COLORYELLOW;
STICKLINE(VAR31=54,L*0.95,L*0.98,8,0),COLOR006600;
DRAWTEXT(VAR31=54,L*0.95,'55天'),COLORYELLOW;
STICKLINE(VAR31=88,H*1.05,H*1.02,8,0),COLOR00FF00;
DRAWTEXT(VAR31=88,H*1.06,'89天'),COLORYELLOW;
STICKLINE(VAR31=143,L*0.95,L*0.98,8,0),COLORCCFFFF;
DRAWTEXT(VAR31=143,L*0.95,'144天'),COLORYELLOW;
STICKLINE(VAR31=232 ,H*1.05,H*1.02,8,0),COLORFF0033;
DRAWTEXT(VAR31=232,H*1.06,'233天'),COLORYELLOW;
STICKLINE(VAR31=376,L*0.95,L*0.98,8,0),COLORFF9966;
DRAWTEXT(VAR31=376,L*0.95,'377天'),COLORYELLOW;
这是黄金分割的主图

请教老师如何实现通达信自动画线功能!

画线函数是不能放在选股公式里的应该放在指标公式里,
Ctrl+f 公式编辑器