当前位置:首页 > 问答

同花顺成交对比改成通达信

我来帮TA回答

求助高手将同花顺的成交金额指标转成通达信能用到的,谢谢

请把同花顺的指标公式源码发上来才好帮你改,。。。。

把同花顺版本的指标修改成通达信版本的指标?

两个软件有太多函数不同。
这要看具体的指标代码才知道是否可以修改成功。

如何把同花顺指标变成通达信指标

MTR:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);HD:=HIGH-REF(HIGH,1);LD:=REF(LOW,1)-LOW;DMP:=EMA(IF(HD>0ANDHD>LD,HD,0),N);DMM:=EMA(IF(LD>0ANDLD>HD,LD,0),N);PDI:DMP*100/MTR;MDI:DMM*100/MTR;ADX:EMA(ABS(MDI-PDI)/(MDI+PDI)*100,MM);ADXR:EMA(ADX,MM);N和MM分别是参数,需要在参数栏设置。PS1:这位同学你可熬得真晚。身体最重要。PS2:同花顺和通达信主要是在EMA,和EXPMEMA上有区别,以及同花顺IF函数貌似不能用&&.

请哪位高手帮忙把同花顺指标修改成通达信指标,谢谢

这公式也不用改啊直接放在通达信用就可以了,把最后一行-10;删了就可以了

VAR3:=LLV(HIGH,240);

VAR4:=100*(CLOSE-VAR3)/VAR3;

VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;

VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;

VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;

VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;

VARA:=BARSCOUNT(CLOSE);

VARB:=VAR8<20 AND VAR9<23 AND VARA>35;

VARC:=VARB AND COUNT(VARB,1)=1;

VARD:=EMA(CLOSE,21)-EMA(CLOSE,8);

VARE:=EMA(VARD,5);

VARF:=TROUGHBARS(3,6,1)<4 AND CROSS(VARD,VARE);

VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);

VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);

VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);

VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);

VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);

VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);

VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);

VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);

VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);

VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);

VAR1A:=EMA(VAR19,100);

VAR1B:=2*(VAR19-VAR1A);

VAR1C:=POW(VAR1B,3)*0.1+POW(VAR1B,1);

VAR1D:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));

VAR1E:=EMA(VAR1D*0.97,3);

VAR1F:=(HIGH+LOW+CLOSE)/3;

VAR20:=(VAR1F-MA(VAR1F,14))/(0.015*AVEDEV(VAR1F,14));

VAR21:=CROSS(VAR1E,LOW);

选股买点: VAR10, COLORYELLOW;

组合买: (VAR11+VAR13+VAR15+VAR17), COLORRED;

组合卖: (VAR12+VAR14+VAR16+VAR18), COLORGREEN;

黑马线: IF(MONTH<2008 AND VAR1B>0.1,VAR1C,0)*1, COLOR6699CC;

黑马信号介入点: 选股买点 AND VARF AND VARC AND VAR21 AND VAR4<0 AND VAR5<2 AND VAR6=0, COLORFFFF99;

DRAWTEXT(VAR13,0.6,'●'), COLORRED;

DRAWICON(组合买,组合买,1);

DRAWICON(组合卖,组合卖,9);

DRAWTEXT(黑马信号介入点>0,4.5,'●我的黑马介入点'), COLORRED;

DRAWICON(选股买点>0,4.2,1);

DRAWTEXT(选股买点 AND VARF AND VARC,2.8,' 30%下单莫错过!'), COLORMAGENTA;

DRAWTEXT(VAR18,3,'空仓'), COLORGREEN;

DRAWTEXT(VAR20<-110 AND 选股买点>0,2,'选股买点'), COLORYELLOW;

DRAWTEXT(VAR17,1.3,'发现黑马'), COLORFF6600;

DRAWTEXT(选股买点 AND VAR20<-100 AND VARF AND VARC>0,4.1,'★组合5分钟线选股思路获利5%以上'), COLORRED;

同花顺决策家选股软件好用吗

一般,关键靠自己选股原则,软件都是通过信息反馈出来的,你也可以通过分析做到的;

同花顺决策家增强版软件好不好用,对做股票帮助大吗?

我觉得版面太花哨了,其实那些都不是很重要