当前位置:首页 > 问答

通达信自动划线指标公式

我来帮TA回答

求助:通达信,股价斜下高点连线自动画线公式,先谢了哟!

将以下公式中的N换成5来用,你没说具体的高点指什么高点,只好给你这个了。
A1:=REF(H,N)=HHV(H,2*N+1);
B1:=FILTER(A1,N);
C1:=BACKSET(B1,N+1);
D1:=FILTER(C1,N);
A2:=REF(L,N)=LLV(L,2*N+1);
B2:=FILTER(A2,N);
C2:=BACKSET(B2,N+1);
D2:=FILTER(C2,N);
E1:=(REF(LLV(L,2*N),1)+REF(HHV(H,2*N),1))/2;
E2:=(H+L)/2;
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(C)=1;
L1:=(D2 AND NOT(D1 AND E1<E2));
H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);
L2:=LD OR ISLASTBAR OR BARSCOUNT(C)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);
R1:=BACKSET(ISLASTBAR,BARSLAST(HD)+1);
S1:=R1>REF(R1,1);
T1:=BACKSET(ISLASTBAR,BARSLAST(LD)+1);
U1:=T1>REF(T1,1);
R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2);
S2:=R2>REF(R2,1);
T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2);
U2:=T2>REF(T2,1);
短期压力:DRAWLINE(S2,H,S1,H,1),LINICK2,COLORRED;
短期支撑:DRAWLINE(U2,L,U1,L,1),LINICK2,COLORGREEN;

请教老师通达信自动画线公式要求:单K线的涨幅在0.5%~3%,画线值为此K线涨幅的中间值

你所指的单K线是什么?
恕我愚笨,仅个人理解,你所说的:“单K线的涨幅在0.5%~3%,画线值为此K线涨幅的中间值”,就是只要达到“单K线的涨幅在0.5%~3%”这个条件,就在该涨幅均值处画线;
但画线一般取阶段性高或低点(或者其它特定条件,比如历史高点或低点等),不能随意画(那样屏幕上会被画线占据满而失去画线的意义);
另外,你给的“0.5%~3%”是一个不确定的值,系统是无法判断究竟是取该区间的哪个值,你再琢磨一下,把你的意思完整地告诉我,最好有图。

求通达信自动画线公式

这个问题要参考绘图函数DRAWLINE的应用,举例如下:
DRAWLINE 绘制直线段
在图形上绘制直线段。
用法:DRAWLINE(COND1,PRICE1,COND2,PRICE2,EXPAND)
当COND1条件满足时,在PRICE1位置画直线起点,当COND2条件满足时,在PRICE2位置画直线终点,EXPAND为延长类型。
例如: DRAWLINE(HIGH>=HHV(HIGH,20),HIGH,LOW<=LLV(LOW,20),LOW,1) 表示在创20天新高与创20天新低之间画直线并且向右延长。
由于你提供的信息有限,只能回答到这一步了,仅供参考。

请高手帮我再改个通达信划线预警选股公式

HIGHN:=10;
AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
高点压力:=DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORGREEN,LINICK2;
相对高点:=DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1);
主流资金:=EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3);
非主流资金:=EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3);
CROSS(C,相对高点) AND 主流资金>非主流资金 AND 高点压力>REF(高点压力,1);

请教老师如何实现通达信自动画线功能!

画线函数是不能放在选股公式里的应该放在指标公式里,
Ctrl+f 公式编辑器

有没有在炒股软件里随意划线的软件?

画线软件目前手机版本应该还没有出现的吧,都是电脑版本的,我一般都用通达信和同花顺,当然我一般也不咋用画线的,你看盘久了就有了盘感,画线实在多此一举