当前位置:首页 > 问答

通达信自动画线指标

我来帮TA回答

求高手写个通达信当天开盘价在分时图上自动画线的分时主图指标?谢谢!

通达信的指标在他的软件上就有,只不过是官方的,而且是系统的

请高手中的高手,编写一个通达信的自动画线公式,(包括长期趋势,中短期趋势线)

{N:=75;P:=5;P1:=10; 参数范围1---100}
A1:=REF(H,P)=HHV(H,2*P+1);
B1:=FILTER(A1,P);
C1:=BACKSET(B1,P+1);
D1:=FILTER(C1,P);
E1:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);
F1:=E1>REF(E1,1);
短压:DRAWLINE(D1,H,F1,H,1),COLORCYAN,DOTLINE;
A2:=REF(L,P)=LLV(L,2*P+1);
B2:=FILTER(A2,P);
C2:=BACKSET(B2,P+1);
D2:=FILTER(C2,P);
E2:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);
F2:=E2>REF(E2,1);
短支:DRAWLINE(D2,L,F2,L,1),COLORLIRED,DOTLINE;
AA1:=REF(C,P1)=HHV(C,2*P1+1);
BB1:=FILTER(AA1,P1);
CC1:=BACKSET(BB1,P1+1);
DD1:=FILTER(CC1,P1);
EE1:=BACKSET(ISLASTBAR,BARSLAST(DD1)+1);
FF1:=EE1>REF(EE1,1);
长压:DRAWLINE(DD1,H,FF1,H,1),COLORGREEN LINICK2;
AA2:=REF(L,P1)=LLV(L,2*P1+1);
BB2:=FILTER(AA2,P1);
CC2:=BACKSET(BB2,P1+1);
DD2:=FILTER(CC2,P1);
EE2:=BACKSET(ISLASTBAR,BARSLAST(DD2)+1);
FF2:=EE2>REF(EE2,1);
长支:DRAWLINE(DD2,L,FF2,L,1),COLORRED LINICK2;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
突破:C>短压 OR C> 长压,NODRAW;
DRAWICON(突破 AND REF(突破,1)=0,L*0.99,1);
手动调节参数以达到最佳效果,一定要提防假突破。

通达信主图如何在在自动画线上面标注文字

这要看你自动画线的条件了
如果是有条件的自动画线就按照条件来呗,例如背离下图的背离画线,这需要源码才能在条件成立时标注文字,或者划线时有数值建立一个新指标引用这个指标根据数值的变化标注文字


如果你要简单之字转向划线那就简单了,
直接按照下面的代码写就可以了
A:ZIG(3,5);
LL:=A>REF(A,1) AND REF(A,1)<REF(A,2);
HH:=AREF(A,2);
DRAWTEXT(LL,L,'底')COLORRED;
DRAWTEXT(HH,H,'顶')COLORGREEN;
主要之字转向是未来函数

求大神 通达信 向前也就是向左侧自动画线?

通达信 向前也就是向左侧自动画线,我可以告诉你,你可以私信我。

求大神 通达信 向前也就是向左侧自动画线?

通达信 向前也就是向左侧自动画线,我可以告诉你,你可以私信我。

请老师做一个通达信自动画线公式 要求:每个波段的最低价向上,画线值是此波段最低价乘1.03.如图

这个指标有么?源代码给我我帮你改 前提只要通达信的