通达信sar公式,怎么提高sar指标的成功率

Q1:SAR指标怎么设置和计算啊

通达信的设置成4,2,20即可

Q2:(通达信)请老师写个SAR周线泛红的选股公式

周线:="SAR.SAR#WEEK";
周线泛红:=周线<C AND REF(COUNT(周线>L,3)=3,1);
日线金叉:=CROSS(MA(C,5),MA(C,10))AND CROSS(MA(C,5),MA(C,30));
MM:="MACD.MACD";
反身向上:=CROSS(MM,0) OR (MM>REF(MM,1)AND REF(MM,1)<REF(MM,2));
周线泛红 AND 日线金叉 AND 日线金叉;

Q3:有哪位高手知道通达信里面指标SAR的参数1-4 和坐标线位置 是如何编辑呢

X:=SAR(N1,N2,N3);{N1,N2,N3,自己在参数里填上}

IF(CLOSE>X,X,DRAWNULL),CIRCLEDOT,COLORRED;

IF(CLOSE<X,X,DRAWNULL),CIRCLEDOT,COLORLIGREEN;

Q4:通达信公式代码中如何在sar上一波红点最高点画一条长横线

稳:EXPMA(CLOSE,7)LINICK2;
健:EXPMA(CLOSE,21)LINICK2;
投:IF(CLOSE>SAR(4,2,20),SAR(4,2,20),DRAWNULL),CIRCLEDOT,COLORRED;
资:IF(CLOSE<SAR(4,2,20),SAR(4,2,20),DRAWNULL),CIRCLEDOT,COLORCYAN;

value_a1:=ref(close>sar(4,2,20),1) and close<sar(4,2,20);

value_a2:=ref(high,barslast(value_a1)+1);

stickline(close,value_a2,value_a2,5,0),colorred;

value_b1:=ref(close>sar(4,2,20),1) and close<sar(4,2,20);

value_b2:=ref(high,barslast(value_b1)+1);

stickline(close,value_b2,value_b2,5,0),colorcyan;

value_c1:=value_a2>=hhv(value_a2,90);

value_c2:=ref(high,barslast(value_c1));

stickline(close,value_c2,value_c2,5,0),colorgreen;

高1:=REF(HHV(H,150),3);
低1:=REF(LLV(L,150),3);
H3:=高1-(高1-低1)*0.5;
中轴:REFDATE(H3,DATE),POINTDOT,COLORLIGRAY,LINICK3;
B1:=EMA(C,12);
B2:=EMA(C,26);
B3:=(B1-B2)*2;
法:中轴+B3;
宝:EMA(法,9);
MACD:=2*(法-宝);
STICKLINE(MACD>0,中轴,中轴+MACD,0,1),COLORYELLOW;
STICKLINE(MACD<0,中轴,中轴+MACD,0,1),COLORLIBLUE;

Q5:怎么分析SAR指标?

SAR指标分析如下:
1.当股票股价从SAR曲线下方开始向上突破SAR曲线时,为买入信号
2.当股票股价向上突破SAR曲线后继续向上运动而SAR曲线也同时向上运动时,表明股价的上涨趋势已经形成,SAR曲线对股价构成强劲的支撑
3.当股票股价从SAR曲线上方开始向下突破SAR曲线时,为卖出信号
4.当股票股价向下突破SAR曲线后继续向下运动而SAR曲线也同时向下运动,表明股价的下跌趋势已经形成,SAR曲线对股价构成巨大的压力

Q6:ENE指标使用口诀

打上轨不跌横盘7天还涨10% 打下轨不涨横盘7天还跌10%
打上轨不跌还涨第3天是高点 打下轨不涨还跌